Streaming live at 10am (PST)

Layout defaults to INLINE rather than BLOCK


#1

Hello,

My LAYOUT defaults to INLINE rather than BLOCK. I can’t change the settings to BLOCK on the div block, and that negatively impacts margins and padding.

As you can see from the attached image, ABC is the default setting. I cannot change the setting. I have deleted the div block and checked the LAYOUT settings for previously built COLLECTIONS and div blocks and etc.

I have recreated entire sections trying to figure this out. I have googled answers for 2.5 hrs the past few days trying to solve this problem. Unfortunately, I’ve come up empty.


Here is my site Read-Only: https://preview.webflow.com/preview/hassans-stunning-project?preview=cec433b5663b5e6a4116584748724b1f
(how to share your site Read-Only link)


#2

Can re-post you read-only link, it’s not working. I’d be happy to take a look for you.


#3

Thanks! It’s the LEADS PAGE

https://preview.webflow.com/preview/hassans-stunning-project?preview=9da4a110081eafc437eb6a6fc852a43b


#4

Okay which part on the leads page? Which exact section?


#5

DIV BLOCK under COLLECTION ITEM LIST in COLUMN 16


#6

No problem, I see it, but read your initial question. It says it’s defaulting to INLINE. There’s nowhere here that says inline in that section. And Inline would be for a text element and that’s about it. Not sure what else you’re referring to.

Look again for the specific element on the page, because it can only be 1. “The page can’t default to Inline, only a text element will do that”.


#7

No, the div indeed defaults to inline. As well as its parent (collection 7). And that one’s parent (collection list 9). Collection List Wrapper 10 defaults to flex, which is also weird. Its parent column is the first in line that is defaulting to block. No idea what’s happening honestly.


#8

The div block in the layout section defaults to INLINE. The div block highlighted in blue, defaults to Inline.

Normally elements on the page default to BLOCK in the layout section.


#9

Yea, I don’t know if it’s a bug or something that I’ve missed earlier in the elements layout. It’s super frustrating and it’s stopping me from finishing the site.

Each time I try to change the settings it reverts back to the original settings.


#10

Ah I see now. Okay here’s the issue. On that parent collection div (COLLECTION LIST WRAPPER 10). You’ll need to double click it in the Designer or the cog, and give it a tag of none. Then you’ll see the grid structure and the div will go to block.

It’ll show your collection boxes where you click in them. And you’ll be able to click again to get the tags for your rows and columns.

Also, before you start binding content divs/boxes. Get the layout structure of your divs first. In essence, get the layout of all the div boxes, and add some sort of sizing. Then bring in content and bind it. If you don’t have content available and you drag in cms collection items, think about it, it’s kind of like empty - BUT - there’s a designation on the grid.

Hope that helps ya :grinning:


#11

I’m going to do this early in the AM and circle back w/ results. Thanks a bunch.


#12

Okay, have a good weekend, take care.


#13

Unfortunately it’s not working. I know exactly what you’re asking me to do, but when I click in the Designer or the cog, the settings option to give it a tag doesn’t come up. I also right clicked and then clicked on settings, and it won’t show up.

I tried to recreate the entire section using the advice given in paragraph #3 - ran into the exact same problem with the div block defaulting to inline and/or flex.

Thanks for all your time and hard work on this. Not sure what the problem is…


#14

Okay after clicking Leads page, then click on sectionTextMessage layer, click on Row 4 wrapper in the canvas, Go to styles in transforms, move Row 4 all the way into the middle so you can see it. Then click the purple Content List Wrapper 10. You’ll get the collection dropdown, select none.


#15

Neat trick man. Very neat and cool. Thanks!!!


#16

Not a problem, have a great weekend. Hope it all works from now :grin:


#17

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.