Streaming live at 10am (PST)

Lightbox bug no scrolling/navigation through thumbnail images


#1

I have been searching for a little while now to find a solution to configure lightboxes with thumbnail scrolling but had no joy. I've found the 3 or so posts which have since been closed and assuming unanswered.

  1. https://forum.webflow.com/t/lightbox-thumbnail-scroll-issue/34467/2

  2. https://forum.webflow.com/t/lightbox-thumbnails-dont-scroll/27280/4

  3. https://forum.webflow.com/t/lightbox-thumbnails-not-scrolling/40602

Is there a solution out there as per @cyberdave video on https://cl.ly/0J123Q3r2C1B

@Waldo @cyberdave or any other staff able to shed some light on this? excuse the pun


#2

Hi @Blaneclorley, thanks for the question, I just checked on a lightbox and for me at least, it is possible to scroll the lightbox thumbs horizontally with the lightbox open in the latest version of chrome Version 57.0.2987.133 (64-bit).

The scrolling is using the center mouse wheel or if you have a trackpad/mousepad, swipe from left or right while hovering over the thumbs. Does that work for you?

Thanks in advance.


#3

Hi @cyberdave I have checked and I am too using chrome 57.0.2987.133 on windows but still having no joy even using the center mouse wheel, so I will try again when at home on my mac this afternoon.

is there a way that when you click/press either of the navigation arrows on the lightbox that thumbnails scroll also? an interaction possibly?


#4

Hi @Blaneclorley, thanks for getting back to me. Hmm.. one thing to check is if there are any browser extensions that might be affecting to the scroll, or custom code perhaps. Could you share the link to the published site?

I would also suggest and try to reproduce the error while being logged into Webflow using Incognito mode: https://support.google.com/chrome/answer/95464?hl=en

If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

Thanks in advance!


#5

Dave,

I've checked my browser extensions and doesn't appear to be anything that would be stopping the scroll. Just checked whilst using incognito mode and error is still reproduced, sorry I can't record my screen at work.

The link to the demo published site is http://bronja-style2-8test.webflow.io and I've used custom code in several places as I've created CMS based lightboxs and sliders whilst using javascript to select the correct opening hours in the marquee scrolling text- I wonder if the custom injections I've used for the lightbox could be the problem? The tutorial I followed for this CMS lightbox is https://forum.webflow.com/t/full-cms-lightbox/33669 .

My custom CMS lightbox can be found under any of the tabs on http://bronja-style2-8test.webflow.io/collections/mother-of-the-bridegroom . But for the purposes of this issue I have crated a standard test page with a normal lightbox at http://bronja-style2-8test.webflow.io/untitled which doesnt scroll either.

Here is a screenshot of the console but I don't think this is what your after...let me know if I've screen shot the wrong thing..


#6

Hi Dave,

Sorry I have just clicked on the scroll wheel on my mouse and I can now get the interaction! sorry I feel kind of stupid now! So thats part of mystery solved!

However my point still stands; is it is possible to add some form of interaction so that if the navigation buttons are clicked the the thumbnails scroll across too?


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.