Streaming live at 10am (PST)

Lightbox not working on exported code

I have a lightbox with a youtube video. When I export my website the HTML code for it is the following:

            </div>
        <div class="hero-image-mask">
           <a href="#" class="w-inline-block w-lightbox">
              <img src="../uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail.jpg" srcset="https://uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail-p-500.jpeg 500w, https://uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail-p-800.jpeg 800w, https://uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail-p-1080.jpeg 1080w, https://uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail-p-1600.jpeg 1600w, https://uploads-ssl.webflow.com/5ee7c0fc53ddfa0bc4f55ac2/5f283d12cdeb74692a0a5686_Thumbnail.jpg 1920w" sizes="(max-width: 479px) 92vw, (max-width: 767px) 95vw, (max-width: 991px) 287.515625px, 429.90625px" alt="" class="image-11"/><script type="application/json" class="w-json">{
                 "items": [
                   {
                     "type": "video",
                     "originalUrl": "https://youtu.be/dA2_dc53OEk",
                     "url": "https://youtube.com/watch?v=dA2_dc53OEk",
                     "html": "<iframe class=\"embedly-embed\" src=\"https://cdn.embedly.com/widgets/media.html?src=https%3A%2F%2Fwww.youtube.com%2Fembed%2FdA2_dc53OEk%3Ffeature%3Doembed&display_name=YouTube&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DdA2_dc53OEk&image=https%3A%2F%2Fi.ytimg.com%2Fvi%2FdA2_dc53OEk%2Fhqdefault.jpg&key=96f1f04c5f4143bcb0f2e68c87d65feb&type=text%2Fhtml&schema=youtube\" width=\"940\" height=\"528\" scrolling=\"no\" title=\"YouTube embed\" frameborder=\"0\" allow=\"autoplay; fullscreen\" allowfullscreen=\"true\"></iframe>",
                     "thumbnailUrl": "https://i.ytimg.com/vi/dA2_dc53OEk/hqdefault.jpg",
                     "width": 940,
                     "height": 528
                   }
                 ]
                 }
              </script>
           </a>
        </div>
     </div>

And here’s the JavaScript:

    i.define("lightbox", t.exports = function(t) {
    var e, n, r = {},
        o = i.env(),
        a = c(window, document, t, o ? "#lightbox-mountpoint" : "body"),
        s = t(document),
        u = ".w-lightbox";

Problem is that when I open the .html document for my website and click on the lightbox nothing happens!!!

1 Like

I have the same problem.
Have you resolved it?