Streaming live at 10am (PST)

Lightbox not working with CMS


#1

Hey guys,

I’ve got a predicament here that I’m in need of some help with.

If you take a look at this page you’ll see that I’ve got a masonry grid (masonry.js) loading in images from a project within the CMS. Each of these images is placed within a lightbox link, however when the link is clicked it does nothing. No lightbox.

I suspect this is because it hasn’t been told which media to load, however the images are loaded from the CMS and I can’t think of a way to get the lightbox to load a corresponding image without breaking the functionality (stopping it from automatically pulling images from the CMS).

Any help would be much appreciated.

Here’s the link to the read-only.


#2

There is nothing loading in your CMS lightbox code,

Screenshot_2018-01-18_090152

That’s because the lightbox is NOT a CMS-ready component and you cannot do it this way

Screenshot_2018-01-18_090123

Here are the other components you cannot use with the CMS: https://wishlist.webflow.com/ideas/WEBFLOW-I-179


#3

Okay, so the lightbox won’t work this way.

How else can I set up the page so that the images open full screen (or in another window if necessary) when clicked on?


Open image fullscreen
#4

You’ll have to use a workaround that involves code and embed component to use the lightbox with CMS. Please use this: https://forum.webflow.com/search?q=cms%20lightbox


#5

Please continue the discussion in your new thread Open image fullscreen