Streaming live at 10am (PST)

Lightbox - Unable to add Media

I seem to have encountered a bug with my project or lightbox.

It seems similar (but not the same) as this thread Lightbox settings doesn't work

I’m building a jewellery brochure site, with lots of pieces displayed in a grid, with a larger image of each piece opening in a lightbox. So far, I have created about 30 lightboxes, but now I am unable to add the image for the Media field. ( I can change the thumbnail image). Instead I’m left with the default image-placeholder.svg

Is there a limit to the number of Lightboxes for each project?

Here is my site: LINK
Here is my Read Only: LINK

Hi @RugbyWebDesign,

Are you using the Lightboxes for the Multi-image field? or as separate image fields from within CMS?

Please don’t forget to add your share link for help/review as well?

Hey @WebDev_Brandon

No not multi-image or CMS just a simple stand-alone Lightbox. https://daventryjewellers.webflow.io/wedding-bands

I added a share link and site link for the forum - are they not working?

Sorry man, didn’t have chance to look deep into it. That’s why i asked. I’ll take a look a bit later. Had to step out for a few hours.

What happens when you try to replace the media? I just jumped in and could.

Hi. I’m in the UK, so out of office now.

However, when I tried to replace the media it just gave me the placeholder image. I copied working Lightboxes from other pages, but when I tried to swap out the existing media file with a new image, it would only give me the placeholder.

Feels to me its either a bug or there is a limit on the number of lightboxes a project can have.

OK, I seem to have resolved this.
To replace the Thumbnail image (highligted in green) - requires one click. In exactly the same way you replace an image inside the image asset.
However to replace the Media Image (highlighted in red) - you are required to double click your chosen image. What’s the logic with this?

1 Like

Thanks SO much Graham! I can’t imagine I would have worked that out without you posting the solution. I’m following along with Meng To’s tutorial; if I listen closely I can now hear him click the image in the Asset Panel TWICE…

1 Like