Streaming live at 10am (PST)

Lightbox video won't open fullscreen

Hi,

I have a video, linked via a Vimeo URL, within a Lightbox on a static page. The video is high resolution and should open in full screen, but when the Lightbox is opened, the video seems to be constrained to a small container (about 50% screen width).

I have exactly the same structure of div containers with the same video playing within a CMS collection - this video opens in full screen. I want the video to always open in full screen and I’m completely baffled why they are opening differently, because everything is the same!

I’ve created a test site to demonstrate:

https://preview.webflow.com/preview/test-triggersss?utm_medium=preview_link&utm_source=designer&utm_content=test-triggersss&preview=07117941aa5b7a04626ec45459a825b5&mode=preview

Any advice MUCH appreciated! Thanks!

Interesting, if you group them you will get the same as the non cms one.
There are quite a few things different with elements when using cms or symbols.
Some have options missing or not applied. hidpi and custom attributes for example.

What we don’t know is which version is correct. The basic element or the cms version.
What we need is a tick box to choose. When that may or may not happens is anyone’s guess but I doubt it be this year.

1 Like

Thanks for taking a look @iDATUS. I guess that means we don’t have a solution for now?

I don’t have a solution but like you found the topic interesting. I was at least able to replicate a standard lightbox. Lets hope someone else has seen this. I would also suggest loging a support call to see what webflow replies with.

1 Like

Thanks @iDATUS ! I have logged a query with support, so hopefully will have an answer soon :crossed_fingers:

I got a response from the support team (great service!).

The solution I now have is to add the following custom code to the head of the website:

<style>
.w-lightbox-frame, .w-lightbox-embed { width: 100vw; height: 100vh; }
</style>

I’m not sure they understood the original issue (perhaps I didn’t explain correctly), but I’ve directed towards this thread to flag it.

1 Like

Well speedy and we got a solution as well!

So I have been testing it and you can put this in the body which helps with speed.

both the class names are built in so you can not change them nor do you need to add any off them to your lightbox