Streaming live at 10am (PST)

Limit to siblings help


#1

Hey there,

A usually simple hide/show interaction isn’t working out at the moment.

Anyone spot where I’m going wrong?

I’m looking to show/hide the “Show abstract” and “Hide abstract” links and control the “abstract and authors” div with the paragraph in it. I’ve set the interaction to “all elements with class” at the moment so it’s easier for anyone who can help to play around with it, but I think I would need to use the “limit to siblings” option to get it working properly


Here is my site Read-Only: https://preview.webflow.com/preview/wernig-laboratory?utm_source=wernig-laboratory&preview=210a5dfb3f39ff5dfb46afdcaecec42e


#2

This link no longer works.

Please update page and what it is you are trying to ask help on?


#3

Have updated the share link, thanks.
The Show/Hide interaction is what I need help on, specifically at this point the “Hide abstract” link in the “Publications” section – the “Hide abstract” link remains visible even when the interaction is set so that it should hide itself when it is clicked.


#4

Please paste the link here.


#5

I think the link stays the same, just the user activates or deactivates it, I might be wrong though, this is the current one 100% https://preview.webflow.com/preview/wernig-laboratory?utm_source=wernig-laboratory&preview=210a5dfb3f39ff5dfb46afdcaecec42e


#6

@doyourthing Tristan, you are missing a few steps here.

But let me try to clarify what you are trying to do?: You want to be able to View the content when you click “View Abstract”, but not have the “Hide Abstract” show, correct? Secondly, you want “View Abstract” to go away when the content is visible and just have the option for “Hide Abstract” be visible, correct?

If that’s the case, it might be easier to restart these animations one at a time. WHen I removed all Hide/Show and reattached them, it worked fine. You are missing connections, that’s for sure.


#7

Thanks for this – Correct, I want to show the paragraph content when you click “View Abstract”, but, for “Hide Abstract” to only become visible at that point, almost like a toggle between View/Hide?

I’ve tried removing all interactions and attaching them, even rebuilding the interactions again from scratch (not complicated interactions so it’s quick) but it didn’t work as described.


#8

Tristan,

I am working on some other projects today. I won’t have a chance to look at it again until at earliest tomorrow. If you can wait til then, fine, but if not reach out to someone else for help.

Sorry my steps didn’t work for you.


#9

Appreciate your help. I’ll be working on this more today and hopefully find a solution. Will be sure to post back on here if I work it out.


#10

Think I got the solution through your steps which were confirmed by webflow support with a handy lil video, so should be all good, but yet to put it into practice yet so will report back again when I have. Cheers!


#11

Yep, I got it in the end, thanks again…
I ended up going with a combination of ‘limit to siblings’ and all elements with class.

(https://preview.webflow.com/preview/wernig-laboratory?utm_source=wernig-laboratory&preview=210a5dfb3f39ff5dfb46afdcaecec42e)