Streaming live at 10am (PST)

Link Block is always opening NEW Tab


Hi there,

I have a Link Block, I am sure that (open in new tab) is not checked (In Link Setting)
However it is still opening the Linked page in NEW tab
I don’t want it to open new tab.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

BUG in Link Block

Try creating a new Link block element applay your styling and move yoy child element to the new link block


Thank You for replying … But its still not workin
I am trying to do Link Button Instead of Link Block.


Can you pls add your share link


This is my project

In (Our Products) Page you will find 2 groups of links
the first 4, these are i created with normal Link Button
the second 4, these are the old ones (with Link Block) that Insisting to open new tab.


In Preview Mode it looks great.
But when i upload it to the hosting space it will start opening new tab
You can check this Link:


OK i can se your problem. Everyting looks ok. Since i cab’t change your project can you try following.

Can you create a brand new Link block Then copy the Design Jet to that livk block.
then try again, if it works add your class DesignJet Block Link to the new Link block and try again.

Im not sure it will work but give it a try.


I tried that …
But let me try again & i’ll let you know.

Thank you for your time


Now It works …
But what can i understand from this??
I mean what is the reason??
Once i have to redo all the page Items, What was my mistake??


I’m not sure you made any misstake. I think is a BUG. I have experied similair things with another elements when i have been doing alot of changes tot it. Will report this as a BUG.


Has anybody found a solution for this yet?

It only seems to be happening with external links (page links work). I’m using a text link and have tried deleting and remaking the buttons but it is still happening… I’ve tried different types of button and links and link blocks and they’re all doing the same!

From what I gather off other forum posts this seems to be a Webflow bug… but I really need a fix asap!