Streaming live at 10am (PST)

Link on Facebook not generating a preview image

I’m having an issue where I want to advertise my site on facebook but the logo or preview image isn’t displayed. it just ‘Not Found’ under the url. We are launching the sale friday and it’d be great if I could sponsor our logo with the link.

1 Like

Hi @Brandon_Ostrander welcome to the community.

Is your Opengraph field filled in with a URL to your preview image in the SEO settings of your homepage ?

1 Like

@Brandon_Ostrander Your URL is not unfurling the image on any platform. Like @ColibriMedia said, make sure you have a link to a hosted image under your page settings. First, you can get an image URL right in Webflow by uploading the OpenGraph image to your assets panel, and then find that image in the panel and click the small arrow:

Next, you can go into your home page settings (or any page) and paste that URL in the OpenGraph URL input section:

If you’re still having trouble with Facebook specifically, make sure you post your link into Facebook’s link sharing debugger so that it will unfurl your updated URL. Feel free to tag me if you have any other issues.

Thanks and good luck!

@myonke I’ve followed your instructions. However Facebook is telling me this via their debugger:

caution-solid Warnings That Should Be Fixed

  • Bad Response Code

URL returned a bad HTTP response code.

  • Inferred Property

The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.

  • Missing Properties

The following required properties are missing: og:url, og:type, og:image, og:description, fb:app_id

When and how we last scraped the URL

Time Scraped 5 seconds ago
Response Code 404
Fetched URL http://www.newtoyouavl.com/
Canonical URL https://www.newtoyouavl.com/www.newtoyouavl.com

5 likes, shares and comments (More Info)
Redirect Path Input URL arrow-right http://www.newtoyouavl.com/


301 HTTP Redirect arrow-right https://www.newtoyouavl.com/
rel=“canonical” Meta Tag arrow-right https://www.newtoyouavl.com/www.newtoyouavl.com/
301 HTTP Redirect arrow-right https://www.newtoyouavl.com/www.newtoyouavl.com
Link Preview NEWTOYOUAVL.COM

Not Found

Based on the raw tags, we constructed the following Open Graph properties

og:url https://www.newtoyouavl.com/www.newtoyouavl.com
og:title Not Found
og:description
  • <meta content="google-site-verification=IWd3I02JoafnjuOm2y_c03XOzDeOBPlgrBW8I6zJgKA" name="google-site-verification" /

Hm…can you share your read-only link so I can take a look? Just Google how to share your Webflow read-only link if you haven’t done it before. Also, can you drop a screenshot of your hosting settings (found under the hosting tab in project settings). I will see if I can spot anything off!

@myonke How would I do that?

Share a read-only link | Webflow University.

Also, can you drop a screenshot of your hosting settings (found under the hosting tab in project settings).

@myonke Webflow - New To You

Please send this too.

@myonke what in particular do you need to know from my hosting settings?

Try clicking the “make default” button on the URL with the “www” in front it. Publish and run it through the Facebook debugger tool again. See if that does the trick! If not, I am not sure what else to try as everything appears to be setup correctly after you make the www version the default URL.

Yeah I’m not sure if I need to include a meta in the open graph settings. Idk what else to do about this right now

I saw you had that meta tag inside the custom code section of the home page. I don’t know why you’d need that? Have you tried it without that in there? Always make sure to run it through the FB debugger tool before trying to see if it works again. It’s working on all other platforms but FB which is weird.

Yeah I dunno at this point. I’ve a few bugs to work out but this one is just a pain. I’m going to do a nuke option with the meta and see if that works. Thanks @myonke

It seems that all of the necessary meta tags are provided in the exported code. Does something conflict? @myonke

Not that I can tell, but this is not my expertise. I think I have helped as far as I can take it. I’m sorry I couldn’t get you to a final solution. Everything looks normal from what I can see, so at this point, I am going to blame it on Facebook. That may or may not be the case though.

hi there,
webflow is missing the “og:url” tag.

Any of your pages you want to work as expected in FB, you have to add the following in the header custom code section of that page : meta property=“og:url” content=“https://example.com/examplepage