Streaming live at 10am (PST)

Link Settings - Phone Link Behaving Weirdly


#1

Hi there,

I am in the final stages of testing everything on my new website and have an issue with the link settings, Phone Link.

On the “Contact Us” page, I have created a CTA which is only visible on mobile. It’s a button with a call link. it worked fine until yesterday when it started behaving strangely. It now redirects and another page on the website despite being configured to be a Phone Link.

I have looked and looked at the issue but cannot find where the problem comes from. Any help would be welcome at this stage :slight_smile:

Page with the problem is the following on mobile: http://speak-institute.webflow.io/contact

Here is my site Read-Only: https://preview.webflow.com/preview/speak-institute?preview=f301df667e474b925e02f0fbec0942c5


#2

Hi @Jake,

Thanks for posting about this.

I took a look at the link settings and seems you need to add the phone link:

Hope this helps :slight_smile:


#3

Hi @Nita,

Thanks for your reply. But the issue is on mobile and not desktop. One the mobile version I have a button and the number is set as you can see in the screen shot below. But instead redirects to a random page on the site. Any idea why?


#4

Hi @Jake,

Thanks for letting me know :grinning:

Seems that you have a Link Block partially overlapping the phone button - try changing the layout by spacing these links, so that those don’t conflict.

Another option, would be increasing the Z-Index of the Phone button.

Please let me know if this solves the problem - If not, I’m happy to help further!


#5

Hi @Nita,

You’re a lifesaver! Looked at everything apart from that. It now works. :slight_smile:

Thank you so much! Have a great day!


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.