Streaming live at 10am (PST)

“Link to section” is linking to wrong section?


#1

Linking to a section on my site is linking to the wrong section...

1st link - links with itself (1st section), that's good
2nd link - links with the 1st section, should link to 2nd section
3rd link - links with the 2nd section, should link to 3rd section
4th link - links with the 3rd section, should link to 4th section

Here is my website link:
http://charlottes-portfolio.webflow.com

Hope you can help,
Charlotte


"Link to section" is linking to wrong section? 2.0
#2

Hi Charlotte, thanks so much for the post smile Could you share your site read only link? If you could share the read-only link to the site, I am happy to take a look.

More information about read-only links:

http://help.webflow.com/general/guidelines#how-do-i-share-my-sites-read-only-link

It sounds like you need to check that 1. All of your sections are located just under the body, and not nested in lower levels of your site navigation structure. 2. Check that your Navbar in the site, is itself in it's own section, that is above the 1st section. 3. Check each section and make sure you have given each section it's own unique ID in the settings panel and 4. Check that the links to the sections in your nav, are pointed at the correct section smile Once you share the link, we can check this out further smile

Cheers, Dave


#3

Hey Dave,

Thanks for the fast reply smile

Here is my link:
https://preview.webflow.com/preview/charlottes-portfolio?preview=007121ae8562e69e98d170fdce285748

I have checked everything all the steps you mentioned and it still doesn't work, maybe you can take a look?

Thanks again,
Charlotte


#4

Just open up a new section and drag the "navbar" within that.

That should help you out.

Looks then like this (i named the new section "navbar" but thats not a must):

Cheers,
Daniel


Section linking with horizontal scrolling
#5

YOU'RE A GENIUS! It worked! Thanks Dan! smile

Also does anyone know how to link a section that lays within scrolled content? e.g. "My Story" text...?

Thanks again Dan!


#6

Hi @charlottestaeck, sections should placed just below the body element. It seems you have the mystory id setup on a DIV, not a section. Those page linkings only work on sections. You can create a new section, drag your mystorycontainer to the new section and then remove the ID you have now on the mystorycontainer and add that to your new section.

I would try that and see if it helps. Just remember to keep your sections right under the body element and all other elements can be within sections smile Does that answer the question? Cheers, Dave


#7

Hey Dave, yep it does answer my questions... sadly. smiley

I want to keep the same effect I have, e.g. when you scroll on the home page, you first scroll to mystory and then you can scroll further through the site... If I were move the mystorycontainer to its own section directly under the body it would no longer work together with the home tab providing the scroll effect... am I right?


#9

when you land on my site (preview or full version) and you scroll down my introduction scrolls away and then "MY STORY" scrolls in and then away and then one is free to scroll my page...


#10

Hey @cyberdave did you happen to change anything on my site because for some reason I can not scroll anymore...???


#11

Hi @charlottestaeck, thanks for your post. No, I have not changed anything. Mostly I was working in the platform support desk yesterday on platform issues, so I have not had a chance yet ot further look at this, but I am going through the forum posts today smile I can take a look. When you say you cannot scroll anymore, do you mean you cannot scroll the page down on your Website?

We never make changes to clients sites without express authorization from the Customer. We always try to guide you to make changes yourself. The purpose of the read only links, is to prevent anyone from making unauthorized changes. I hope this helps. Cheers, Dave


#12