Streaming live at 10am (PST)

Linking to a section, on another page


#1

Hi guys!

I am trying to link this button (below) to another page’s section.

When I try to link:

22%20AM

I don’t get a selection of that section which is called “WORK”, I get nothing:

29%20AM

Would love some help from you! Thanks in advance!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Try using the external link option then put a /, the slug, a # and the ID of the section.

For example. If I had a team page with a slug of team and the section I wanted the page to go to directly had an ID of nelson, the external link would look like this:

/team#nelson

Hope this helps :slight_smile:


#3

@PixelGeek Hi Nelson, Thanks! But didn’t work :frowning:
Here is what I wrote, please let me know if that is correct? So it’s on the Home page, and the section on that Home page is WORK

56%20PM


#4

If you’re linking to a section in your home page you don’t have to write ‘home’ just put /#WORK and that should do the trick.


#5

@aaronocampo I am linking from one page (Project) to a section on another page (I have a long scrolling Home page that has a WORK section) and that is where I want to link it to…


#6

Like @PixelGeek mentioned you just need to add the /, the name of the page and then the #section.

In this case, because the section you want to link to it’s in the home page you don’t need to add ‘home’ after the / just the #section (in your case the whole syntax should be /#WORK


#7

@aaronocampo But isn’t that what I did? Please see above, I wrote “/, HOME, #, WORK” (so the page I am linking to and then the section on it)…


#8

@aaronocampo and I tried just doing #WORK and that didn’t do anything either.


#9

Can you share you’re read only link please?

I can make a small video to show you.


#10

@aaronocampo Sure thanks so much!

https://preview.webflow.com/preview/marinas-first-project-36f0e9?preview=f9ecc6e498584765426ac6820f35e20d


#11

One thing you have to have in mind here is that this only works in your published site and not the preview mode. Are you trying this in preview mode or the published site?


#12

@aaronocampo Ah! I see, yes preview :slight_smile: I want to make sure everything works before I publish it!


#13

No problem, you can always publish to the webflow subdomain to test everything out. Can you check there please?


#14

@aaronocampo Oh I didn’t know that, and not quite sure how to do that… Is there a video on this? I would definitely like that!


#15

Screen_Shot_2018-05-15_at_20_46_33

Just make sure that the first webflow subdomain option is ticked and the ‘custom domain’ isn’t that way you’re just publishing changes to the ‘testing site’ and once you’re ready you can publish to the custom one.


#16

Thanks @aaronocampo! So I published it, but when I tested it and clicked on that button this is where it took me:


#17

Hi @visualcravedesign

You’re still using the wrong link:

Screen_Shot_2018-05-15_at_21_28_51

You’re link should be like this:

and, is this in the webflow published subdomain?


#18

@aaronocampo thanks for that visual!! Super helpful!!

So I published this this, Is this correct?

20%20PM

When I tried to do your new link, it took me to this, so maybe I published wrong?


#19

That’s perfect!

Now click on the little arrow that takes you to the published site:

Screen_Shot_2018-05-15_at_21_39_37

Once you’re there you can try the button.


#20

@aaronocampo ok thanks!

Ugh this is where it took me :frowning: