Streaming live at 10am (PST)

Linking to PDF files hosted on webflow


#1

I will be publishing a site very soon and I need to link to a few pdf files that will be hosted on webflow. This is the staging site (http://innovatus.webflow.io)

There are two issues I’m having:

1 - two of the PDFs are linked from pages in a slider, and those links do not open the pdf in a new window as indicated. The ‘Open in a new window’ box is checked, but the link jumps directly to the pdf which requires the user to hit the ‘back’ button I the browser to get back to the site. I need all links to pdf files to open in a new window.

2 - I’d like the pdf files themselves to have a link url which matches the domain, i.e. innovatusimaging.com/PDFname. How do I do that?


#2

Hi @pminnelli, thanks for your post. Let me help to comment on your good questions:

  1. At the moment there is an open issue with the “Open in new Tab” link settings for some kinds of links. Could you try uncheckng that and see if the behavior reverses, i.e. a new window opens when the “Open in new Tab” is unchecked?

  2. At the moment it is not possible to mask the urls to media in the Asset Manager to the domain name. That is a good idea and you are not alone, I encourage you to vote and to leave your comments for the Webflow team here: https://wishlist.webflow.com/ideas/WEBFLOW-I-839

Let me know about the links in the slider, if still an issue, I will go take a further look.


#3

Ok, this is weird, I relinked both of the pdf files and both are opening a new window, but one of them has “Open in new Tab” checked and the other is unchecked. It seems to have to do with the order of steps when I link the attachment.

In the case of the one that’s unchecked, I linked the attached file while the box was checked by default, and did not open in a new window. Then I unchecked the box and it is now opening in a new window.

In the other case, I first unchecked the box, and then selected the pdf attachment. With box unchecked it did not open a new window. I went back in and checked the box and now it’s opening in a new window.

So it appears you need to uncheck the box first, then select the file, and then check the box. Any ideas why this is so?


#4

Hi there,

Thanks letting me know. I do not have an immediate answer, but I will add this information to our open issue case on this and let the dev team of this behavior with the pdfs and open in tabs links.

As soon as I have more info the the open in tabs fix, I will post back here with that info.


#5

Hi @pminnelli, is your #1 issue the same as this?

Embed PDF in webflow page? or push PDF into new browser window?


#6

No, the ‘open in a new window’ box was always checked and never unchecked itself. I had to manually uncheck it.


#7

Hi @pminnelli, an update was pushed out on the open in new tab link settings, let me know if any further issue with the pdf links.

Thanks in advance,
Dave


#8

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.