Streaming live at 10am (PST)

Links not working inside FX Wrappers


#1

Continuing the discussion from Strange behavior of text link:

I moved the discussion to the bug section, as something seems strange here...

Here's am example for what my structure looks like:

I have a "Text FX" container, which I use as a wrapper to show/hide a section.

Within the contained paragraph you see a modal link (Text Link)

When I open the Text FX wrapper, the section opens as desired and I can quickly click on the text link and make the modal window work. But as soon as the interaction script is finished running, the link is "disabled". I can no longer click on it.

I am having the same issue on another page of the site, where I have a link between two paragraphs in a FX wrapper.

I have tried everything, any help is much appreciated.

Tobias

https://webflow.com/design/boli-pura?preview=49f9db88d717fc30f20df784464c687e


#2

You haven't put any link on your link element. The # character usually help getting the hand cursor, but here for any reason you don't get the hand cursor. But give a proper link URL to your element and you can actually click it.


#3

You are talking about this link here, right? In the folder "Essenzen" on the page "Essenzen"

There is a # in the Link window

Or are you talking about something else?

Again, the link works, as long as the interaction script is still running and doing stuff (for a few seconds). Once the interaction is finished, I am no longer able to click on the link.


#4

Yes

Put a real link here and you'll see the link works. We put a # in a link to provoque a hand cursor usually but it's not a link.


#5

Hi Vincent,

just to be sure, here's where I am coming from:

I am not quite sure what you mean by assigning a real link to the modal link, as it just a trigger for the modal script.

Thank you for your patience on this.

Tobias


#7