Streaming live at 10am (PST)

Links to collection pages from (say) home page


#1

EDIT: After more searching and watching another Webflow video on CMS what I’ve come to understand is that I’m “missing” the purple page link selection on my Link Settings panel (and also when you click on the element gear). The question is why? It shows up if I’m on a Collection Page (like my Blog Post page) but not if I’m on my Home page. Does that mean I can only link to Collection pages from other Collection pages, and not from a home page? That makes no sense whatsoever but that’s how it’s looking at the moment.


I’ve read quite a few posts that seem to ask the same question I have but with no specific answers (I’m sure I haven’t read them all, so the answer is probably hiding somewhere).

I made a new CMS collection for blog posts and added one (a blog post that is). I then went to the Blog Post Template Page under “Collections Pages” in the left sidebar and put that page together by pulling in the CMS information (into the appropriate elements). That worked great, so I finished styling the page a bit.

Next, I went back to my home page and wanted to point a Text Link in my menu area (of the home page) to the Blog Post page. No dice. When I click on the gear that’s attached to the Text Link and choose “Page” as the link type, it shows me the other pages I already built (not are CMS pages) but it does not give me the option to link to the Blog Post Template page.

Just to make this clear: there is no CMS content on my home page (no Collection List) and the CMS content page I built (the Blog Post Template page) is working fine, that is, all the CMS content is showing up in the right places. I’m not trying to “point” to any specific element or specific content from the CMS collection, I’m just trying to click on a link on the home page and be taken to the Blog Post page.

This has got to be a simple thing I’m just overlooking. I’ve banged my head on much more difficult tasks in Webflow and figured them out but this darn simple link from the Home page to the Blog Post page has me stymied.

Thanks in advance for reading this and for whatever help you can offer.

Edited to add:

Share Link: https://preview.webflow.com/preview/nwcwd?preview=040a6d5237dc968ae20b2765b0759841

Les


Here is my public share link: LINK
(how to access public share link)


#2

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.