Streaming live at 10am (PST)

List Items change to generic "text" after typing


#1

Hello gang.

I’m new to Webflow and have been encountering a handful of weird bugs. My system: imac running El Capitan (had to downgrade because Sierra and High Sierra had major bugs in them). The issues I"m facing happen in both Chrome and Safari.

So here’s the thing: I’m doing the Webflow tutorials and keep having strange things happen. I’ve already reported a couple of them in another post, but here are two more:

problem #1: I created a div and filled it with a bg image right from the tut files. I noticed that as I set the styling for it, my photo of “Janet” was cropped in close, while the tut showed her face zoomed out more and with some detail on the right side (which was cropped out in my version).

I had to delete my div which contained the image, and then recreate it. Same thing was happening! So I deleted it again and this time created another div with a different class name. That seemed to solve the problem even though the new class name had the exact styling as the old class name! If I chose the old name, the image was cropped again. Weird.

problem #2: I dragged in an unordered list and began naming the list items. After each name was typed, the “list item” suddenly changes to “text”! I deleted the UL and tried again - same thing.
I’ve left it as is so that someone can go in and see what’s going on.

It is frustrating, because I really want to learn Webflow and subscribe to do more, but I’m gun-shy because of these bugs.

Any thoughts?

Thanks in advance,
B.


Here is my site Read-Only: LINK
https://preview.webflow.com/preview/portfolio-introduction-tut?preview=c3088869562b119880b81061fc610629


#2

Hi @bellybuckle

Thanks for posting about this.

Problem 1 sounds like it may have been a style issue. If the background image wasn’t set to cover on the first class, the image may have appeared to be cropped. What you can do to check this is add two divs and give them each one of the class names – then compare the settings between the two. I’m happy to check this for you if you want to set up this design for me to look at.

I’m not able to see problem 2 on this end, the list item remains a list item when typing directly into it:

Feel free to send a screen recording if you see different behavior. If your list items are changing to a text block, you also have the option to nest elements inside the list item to avoid this.


#3

Hello again Brando. Thanks for responding :slight_smile: Sorry it’s taken me so long to get back to you.

Ok, so first problem: I wish I hadn’t deleted the div and created a new one - I could’ve shown you. But what I do recall is that yes, it WAS set to cover. I’ll remmeber to do the test you’re suggesting if I encounter that again.

Second problem is weirder. I just reopened the file after weeks, and suddenly it’s working the way it should (list items remain list items after I type text in them).

But these issues, along with a few from the last tutorial I’ve done, make me want to ask this question: if I were to delete my account and open another one, I wonder if that would make a difference at all?

Do you think I need to go to that degree?

Thanks,
B.


#4

Hi @bellybuckle

No this wouldn’t make a difference. Logging out and logging back into your Webflow account, or even a refresh of the Designer, is enough to get the latest build from any updates the team has pushed.

Happy to hear it’s all working now – Let us know if you see any other odd behavior!


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.