Streaming live at 10am (PST)

Lottie Animation blink on reset

Hi Everyone

I can’t believe that I am the first person with this issue but I am having problems finding a similar thread. My problem is fairly simple (i hope).

If you check the share link below I am trying to play looping lottie animations (on all breakpoints except desktop). The problem is that every time the animation completes a loop, it looks like it disappears and loads the animation again instead of just jumping into the first frame of the next loop. This creates a blinking effect after every loop.

You can find an example on the bottom of the home page (fly fishing reel) or the top of the 360 page (camera).

Here is a link to the staged site (https://freefour.webflow.io/360), if you load it on mobile you should see exactly what I mean.


Here is my public share link: https://preview.webflow.com/preview/freefour?utm_medium=preview_link&utm_source=dashboard&utm_content=freefour&preview=0a098368e71e0681677b1b354c783aed&mode=preview

This is a known problem. Set your animation to play to 99% instead of 100. This will solve the blinking. As to why would this even happen - honestly no idea.

2 Likes

Thanks for helping. Where do I find this setting? I see it for the desktop effect (mouse move over element is working fine), I just don’t see the same option when choosing lottie playback when scrolled into view.

You will need to create a new interaction for that.

1 Like

Thank you very much, this solved it.

1 Like