Streaming live at 10am (PST)

Mailchimp Form Failing, Email coming through as a boolean

Howdy,

Have a weird thing going on a form submission, for context.

  • can be found on the “notify me” button or the “join the waiting list” at the bottom of the page.
  • code exported hosted on Netlify (forms are working > www.killerinteractions.com)
  • Forms are 100% Webflow, the action is pushed to Mailchimp

Issue: Not sure what going on but on mobile breakpoints the form submission is popping up and error. “The opps something whet wrong.”

No idea what’s causing this.
Any help much appreciated

Cheers,
John

__

https://preview.webflow.com/preview/killerinteractions?utm_medium=preview_link&utm_source=designer&utm_content=killerinteractions&preview=fe7aeb0912131ce3f9882a1552e75ef2&mode=preview

Ok Few Updates, nothing to do with the breakpoints. Just happen to be the thing i was testing.
The error in the console is:

Mailchimp integration bug - An email address must contain a single @

Again any help super appreciated

The email field is not actually passing the email address…
‘EMAIL=true’ is being sent.
Was it working before exporting?

Yeh was working before, but I have been messing around with a few things, not entirely sure how it can go from working to switching over to a true statement. Played around with some hidden fields IP, GDPR maybe one of these started to mess with it.

At a guess I would say your div ids are not mapped as expected, or possible your Merge fields on the mailchimp side…

Shall check both, cheers for a possible trail of hope

Both apear correct:

also synced with active campaigns mater list think this could have an effect?

I just like at your preview and didn’t see a form for the mailing list section (which is what I looked at on the published site).
The mailchimp side is fine (I just tested). So I’m fairly sure its your page unless you are using custom code to perfom the submit.

Cheers for the help,

I’m thinking it may be the form name/id. the form is submitted through webflow.
There is one chunk of custom code related to capturing the IP address, thou was working before so i don’t think it’s that.

Shot of the form section

Action: Killer Interactions

I usually set the ‘Form Name’ field to the mailchimp equivalent e.g ‘mc-embedded-subscribe-form’ the ID element form isn’t necessarily required.

Great figured it out was a hidden field for GDPR, which for some reason was creating the issue. Just deleted it. Thanks Gail for the help!