Streaming live at 10am (PST)

Mailchimp Integration Not Working


#1

Hello!

I have a form on my Request Pricing page (http://jsl-marketing-fe91e4.webflow.io/request-pricing).
When I try to send the form submissions to Mailchimp using the form action URL (I’m 100% sure it’s the right URL), I get an error when I try to submit the form.

I’ve tried submitting the form to other Lists (such as elFormo) and it works fine.

Any help is appreciated!


Here is my site Read-Only:
https://preview.webflow.com/preview/jsl-marketing-fe91e4?utm_source=jsl-marketing-fe91e4&preview=17f83186c82186ec719a84b947bab713


#2

Here is a working sample you can clonr


#3

Thanks but this doesn’t help. Like I said my form works just fine when I send the form submissions to various other databases, however I only get the error when I send the form submissions to Mailchimp


#4

Ok but this is a working solution sending to my live mailchimp. Do you get any errors using my sample??


#5

So weird the URL works on your site, but not for mine…any clue why?


#6

The POST action URL = https://thestoryist.us8.list-manage.com/subscribe/post?u=45bec215ab329054ba44685a7&id=0a1ba222d2


#7

What kind of error are you geting? MailChimp or Webflow.
I asume you want to pass all Fields to MC. The naming is very important. Use same name on id and the field in Webflow and be sure they match the field names in MC


#8

Webflow error says Oops something went wrong… you can try for yourself I put the link above


#9

Ok, you can only submit the email once to MC. If you try to submit a name that already is in MC you will get this error in Webflow.

Be sure to delete the email you are testing from MC or change email.


#10

I’ve never had that error before and I’ve used MC with webflow…using the same email


#11

Did it work now ? Or do you still have problem?


#12

Same problem even if I try inputting new email addresses


#13

Ok, Will try to use your link and se what hapoens. Will do it later, holiday today


#14

Thanks Janne appreciate all your help!


#15

I was thinking it might be an issue where the Email tag names didn’t match up but as you can see in the pics, they do.


#16

@rhami i took your mailchimp link and used it in my progra. It looks like i was able to add my email you your newsletter feed. Can you pls confirm that my email is there. janne-w@adbutveckling.se.

If it’s there you know that mailchimp is working. i Guess that the problem is your form.