Streaming live at 10am (PST)

Mailchimp integration redirect


#1

Hi there,

I know this has been asked a lot of times, but none of the solutions seem to work for me. And I have tried all the advice provided.

Whenever I submit the form, I am redirected to Mailchimp’s Sign Up form.

I have tried:

  • Switching the URL from https to http
  • Switching the method from POST to GET
  • Changing the field names to match the tags within Mailchimp
  • Removing the form/fields from within any Divs & Columns

Any help would be really greatly appreciated.

Here is my public share link: LINK

Thanks!



#2

In your Mailchimp account, in the custom Form builder, there’s an option to enter a redirect URL; this is where you’ll put in something like a Thank You page… or whatever you want.

Let me know if you have any further questions.


#3

Thanks for your reply, but unfortunately this won’t help.

I probably didn’t make this clear:

  1. I fill in the form on Webflow, and press submit.
  2. I am redirected to the Mailchimp Sign up form. The form is empty.
  3. I check the List on Mailchimp, and the details submitted from Webflow are not entered.

So it seems that the details are not being passed through to Mailchimp at all.


#4

I’ve solved this.

This was 100% user error on my side. Really foolish mistake.

The Mailchimp URL needs to be placed in the “Action” field of Webflow, not the “Redirect URL” field.