Streaming live at 10am (PST)

Make Navbar links stay on one line


#1

Hello,

For some reason my Navbar text is not staying on one line. I’d like them all to be on one line.

Thanks for the help!


Here is my site Read-Only: https://preview.webflow.com/preview/orca-coworking?utm_source=orca-coworking&preview=68c5c2f01780d0a86eebab9180f3a11e


#2

Hi @rhami

The container you are using for your nav links and logo is confined to 940px, this is the default setting for the Webflow component. Due to the size of the elements within the container, there is not enough ‘space’ to fit the Nav Link text on a single line, hence it is ‘wrapping’ to 2 line.

Your options are:
Reduce padding / Margin / Font size to achieve the look you want (This may not be visually appealing?)

Create your own Container using a Div and setting a Max Width of 1100px. you can drag all your elements from the existing ‘Container’ into your own/newly created container. This option will give you more real estate to work with for your Nav.

Hope that helps
Keiran


#3

Thanks @knk I tried that but it’s still doing the same thing for some reason.


#4

Hi @rhami,

If you change the ‘Flex Item’ setting on your new Div to ‘Expand’ should result in what you want.

See how you go :+1:


#5

thanks so much! great help