Streaming live at 10am (PST)

Making Twitter cards work

Hi,

I’m having trouble making twitter cards work at all.

I paste my site’s URL into the card validator at Twitter, here: https://cards-dev.twitter.com/validator

I receive the message: “ERROR: Fetching the page failed because it’s denied by robots.txt.”

My Robots.txt field is blank in my project settings.

All pages have OpenGraph fields enabled and set.

Is there something obvious I’m missing?


Here is my site: [https://www.bitspark.io/]

Hi @Kristin_Low,

Great question, and thanks for posting about your validating with Twitter.

I believe the next steps is to add Sitemap: https://www.bitspark.io/sitemap.xml to your robots.txt input: https://cl.ly/c41f02c58cf3

Afterwards, feel free to republish your project, and attempt your validation.

It should then work as expected :bowing_man:

Thank you, this worked! One final challenge: some of the images don’t show up in the card when it validates. For example, the url https://www.bitspark.io/for-businesses validates on the card validator with an image showing up. However, https://www.bitspark.io/ doesn’t present an image. I am using the same opengraph image for both pages. Anything I might be missing?

Thanks

Hi, @Kristin_Low!

Are you seeing an image show up now? Sometimes it just takes time to pull everything. I just checked and I am now getting an image for https://www.bitspark.io

CloudApp

Can you check again? We’ll be standing by to help if you’re still having issues!

1 Like

Thank you, it’s all good now. Appreciate the help!

K

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.