Streaming live at 10am (PST)

Menu jumps between open / closed


#1

Hi everyone! I’m new to Webflow and I’m creating my first page.

When I click the menu it opens and closes rapidly, I can’t find a way to fix this. Only happens in the publised link. When I’m in preview mode it works fine.

Here is the link: http://juanitas-first-project-09bbcd.webflow.io/

Thank you for your help :slight_smile:


#2

Hi @jvelezr

Welcome! That’s an awesome first page!

Can you provide your ‘share’ link / preview link please - we can then check through your settings in the designer, and check if it’s a bug or just a tweak needed.

Do you have ‘interactions’ set up to open and close the menu? At a guess this looks like it could be an ‘initial’ state problem, and hopefully easily fixed!


#3

Hi, is this the link?

https://preview.webflow.com/preview/juanitas-first-project-09bbcd?preview=f76e8fe996ceb62aa9e091893676ad50

Thank you!


#4

Hi @jvelezr

Thanks for posting about this! I took a look at your site and tested a few things. It looks like the issue is also affecting a brand new navbar when added to the site. After some more digging, I found the source of the weird menu glitch is from the custom code on your home page:

Once this code was deleted, the menu worked as expected. You may need to refactor that code.

On an unrelated note, I also noticed there is some horizontal scrolling from the absolutely positioned images. To resolve this, you can set the sections of your home page to overflow: hidden (GIF). You may need to move around some of the images that hang outside of the sections so they don’t get cut off completely – moving them to different sections should do the trick.

Hope this helps! :slight_smile:


#5

Thank you for taking the time!!! And noticing the horizontal scroll :slight_smile:


#6

Hi @jvelezr, nice site! I happened to notice at the bottom of your page you want to say ‘Connect’ (so with two ns) and not ‘Conect’. As someone who’s also trying to do a site in two languages, I know I’d appreciate if someone pointed out any small mistakes to me! :slight_smile:


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.