Streaming live at 10am (PST)

Menu showing differently on different pages


#1

Hi @cyberdave, Thank you for the video. Yes, it was very helpful. However, I am continuing to experience problems with the mobile menu. I thought the symbols would be universal across pages, but the menu is showing up differently on different pages. Also, when I try to adjust the logo beginning at the highest mobile level, it's hard to adjust for all levels. The whole design begins to get compromised. On different levels. I am sorry, but I need more help! Side note: This menu has taken me too many man hours to get cohesive across all levels. Client is getting frustrated, as well as me.

https://preview.webflow.com/preview/excellence-in-fitness?preview=186f7132188e21fd74973cd8bbe10385


Menu dropdown disappears under hero slider
#2

Hi @gisijam! Don't give up :slightly_smiling:

On the symbols not looking the same across pages, could you provide a screenshot example of where the symbol is looking different and on which pages?

I am here to help and I am sure the design issue can be resolved quickly.


#3

Thanks @cyberdave. Here are the snapshots to give you examples of how the menu looks different on pages throughout the site. Also, there is a gray background color that comes up on the menu image when menu is expanded. How can I remove that or make it transparent? Also, seems the current menu link needs more space above.








Thanks!


#4

@Waldo, @sabanna, @cyberdave,

Hi, hoping I can get some help on this. Do any of you know how to keep the menu from shifting from page to page, even though it is a symbol and should remain the same?

Thanks in advance!!


#5

Hi @gisijam

I've look into it and I see you also has some more layout problem here and there. My advice you better pay someone few buck to solve them for you. And I am not saying this because I am a freelancer. What I am saying is those are basics and you have some, so you better get someone to fix them if you in hurry.

Cheers.


#6

Hi @gisijam

This problem related to the styling link in the CURRENT state.
For fix it, follow this steps, please:

1) Open the page where one of the menu links appear in the current state, for example, "The Team" page.
2) Double click on the navigation for open the navigation Symbol for editing.

3) click on the menu link "The team", you will see that this link has a CURRENT state

4) click on top padding and remove style

5) go to TABLET mode and open the menu

6) click on the menu link "The team", open style panel and find top-padding setting

7) click on top-padding settings and remove style

As a result all your links will look the same and will not "jumnp" anymore

Cheers,
Anna


#7

This worked perfectly. Thank you. Have you any thoughts on the logo shifting around? Or the grey background that comes under the menu graphic? I deeply appreciate your help. Thanks again.


#8

Hi @gisijam, the solution for the logo is to make sure that the Brand class with the Current pseudo class, as the same margins and padding as the Brand class without the Current psuedo class.

Here is a little video:

I could not find any grey space that you referred to when opening the menu, could you share a screenshot of that?

I hope this helps :slightly_smiling:


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.