Streaming live at 10am (PST)

Messed up Margin maybe?


#1

I’m getting very frustrated with Webflow in that my home page of the site I’m building out for business seems to keep breaking each time caused by a different issue in the code in Webflow. I’ve noticed over the last month or so that there are times after correcting a setting that Webflow doesn’t actually correct itself based on the new settings I’ve selected. I dont have a specific example for this issue I’ve noticed nor have i figured out why the code seems to keep getting hung up like this.

This brings me to my once again major problem I’m having on the same exact page as I’ve had this happen before. Its not the same fix either of these three times now either. Finding what’s causing it like searching for a needle in the haystack… again. Now i’ve spent a full day and half trying to figure out where this current problem lays.

My “home” page of the website (JonLyle.Com - Under Construction) I’m building out keeps creating a margin for lack of better term that makes this particular page of the site twice as wide as it’s supposed to be.

Take a look at the attached image. It looks ridiculous to say the least. I’m frustrated that Webflow is NOT giving me a clear indicator without searching for needle in a haystack and wasting so many valuable hours trying to fix the problem.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Seems to be working fine on my side:
CloudApp


#3

@Jon_Lyle

EDIT: Found it! Remove the overflow setting from the Slider mask. It was basically not hiding the other slides, so the more slides you would have added, the wider the site would have gotten.

CloudApp

:grinning:


#4

Don’t get frustrated, the forum is just a click away! SOMEONE will know the answer, and it’s always nice to have a fresh pair of eyes take a look over something :metal:


#5

Thanks for helping me keep the rest of my hair intact Markos, you were right on!


#6

One more question Markos based on your comments. Keeping the the Legacy and the IX 2.0 animations from mixing on page or the entire site? Assuming you’re referencing the entire site.
I started the project with a free template to help me learn Webflow and just started messing with the animations and hadn’t made it as far as any documentation on Webflow regarding Legacy or the IX 2.0.

I’m a glutton for punishment in learning the hard way to often I guess. Lol


#7

You’re very welcome. Glad it’s sorted.

As for Legacy and IX 2.0, personally I don’t use Legacy at all, just jump right in and use IX2.0. It’s so much easier to use and reusing animation is even easier.

There are many Webflow users creating cloneable elements with animations using IX 2.0 now as well, so if you copy any and want to tweak them to suit your site, you’re going to need to know how to use IX 2.0.

My advice to any new Webflow user; invest your time into two things…
Flexbox and IX2.0 :smiley: