Streaming live at 10am (PST)

MixItUp not working. Where am I going wrong?

Hello, my read only link is below. I had mixitup working on my site before but for some reason it no longer works anymore. Please can someone help me figure out where I am going wrong and tell me what I need to do to fix it?


Here is my public share link:
https://preview.webflow.com/preview/the-travellers-club?utm_medium=preview_link&utm_source=designer&utm_content=the-travellers-club&preview=066bc41efb17dc77e87573b131c15f69&pageId=5ffc1b95dd336b4fe9d07c7e&mode=preview

If your project has custom code or layout issues on the published site, please share that URL/URI.

How do I do that? (Sorry I’m not an experienced web designer)

The published URL is wherever your custom domain or webflow.io domain is. It is where you go to view the site in your browser (not edit).

For the moment I’m just publishing to https://the-travellers-club.webflow.io/
I had been publishing to a custom domain but it wasn’t working before I made some design updates (currently being published on the link above).
The page concerned is - Travellers Club Job Aggregator

Look at your console. Your code is specifying an ID where your page is using classes.

Thanks for replying, but I say again :sweat_smile:, I’m not an experienced web designer and do not know JavaScript.

Which part of my code do I have to change and what do I change it to? I understand what you say about ID needing to be classes, but I don’t know how to identify it.
I tried changing all the document.querySelectorAll(’.filter-group’); to document.getElementsByClassName(’.filter-group’); but it didn’t work.
I also saw for line 37 it says getElementByID so I changed it to ClassName instead of ID but it didn’t work also.

P.S. I didn’t write the code