Streaming live at 10am (PST)

Mobile menu is scattered across the display


#1

Good evening webflow community

Since today were facing the issue that the mobile menu is scattered across the screen. The way the system behaves is currently a huge mystery to us and I will try to retell what happens and happened as close as possible.

Every time we open an English mobile page the whole menu looks like this

The menu button is completely missing and I don’t know how to fix the problem since I basically tried out everything that came into my mind. I highly suspect that its a bug from webflow, since we haven’t had any problems even though I know its a massive mess regarding the classes.

First I tried to fixing it by copying the menu off from other pages where it works and just changing the buttons afterwards - no success. What really made me curious is when I tried to fix it by copying the whole german page and translating it in English the bug still occurred. How is that possible if I copy off a whole page and just translate it that such a bug occurs?

I also tried removing all classes from the buttons in the menu, without success

The other thing that happened was like an hour ago, after deleting the buggy english home version and replacing it with the copied german one it took the whole menu out of the white header in the desktop version, on both pages. However this was only visual and vanished after I F5ed the page.

Mobile tests were made with a HUAWEI P10, an iPhone 7 and an iPhone X

Is it possible that theres currently a bug regarding webflow around or did I miss out on something?

Merry Christmas,
Dominik


Here is my site Read-Only: https://preview.webflow.com/preview/adelmannconsulting?utm_source=adelmannconsulting&preview=b64bc17925d27694d666f0b9bde2d07f


#2

Hey @dadelmann

this isn’t a bug, it’s just miss use of the layout tools. That’s fine, just change your the display of the links from inline-block to block, flex or grid when you are on mobile view. You have a lot of unnecessary margins all over the place and individual classes for each link. Keep you design clean and it will be much easier to maintain and debug.


#3

Hi @gilson

thanks for that very useful tip, this is going to make things way easier in the future, especially when designing responsive. Yes I know there’s kind of a mess regarding the classes, definitely something on the list for early 2019.

But sadly the issue isn’t solved yet, now it looks like this

It’s still not displaying the menu button, any ideas?