Streaming live at 10am (PST)

Mobile navbar wont work

Hello,

I have a problem with my navigation, but only on mobile devices. It’s not possible to click the links in the navigation. I think it has something to do with the class=“w-nav-overlay” that somehow is blocking the links.

I’ve tried to remove it with custom css -> “display: none !important” but it wont work.

Can anybody help please?


Here is my site Read-Only: https://preview.webflow.com/preview/1handplate?utm_source=1handplate&preview=df8d9a1a631b76d2c723e1eed2f6d8e3

And here’s my published site: http://1handplate.webflow.io/

@Hans_Christian_Andre - I looked. Don’t see the issue on Chrome in dev tools responsive mode.

Can you provide the device / browser combo you experience issues with?

Here would be a good test. Copy a page, remove the .navbar (desktop navbar) and then publish and test that page. I suspect an issue with two navbars, but can’t test that on a mobile without publishing.

Hi webdev,

Thank you for your reply. The issue is when you use a mobile device. My phone is a iphone 6 and the issue is also on iphone X.

Tried to make a test page like you said but it’s still not working :frowning:

I figured it out :slight_smile:

It was the menu button and the navbar trigger that was causing the trouble.

I just changed the menu button to a normal div and changed the trigger from “navbar” to “click”

Then the class “w-nav-overlay” was gone.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.