Streaming live at 10am (PST)

Mobile only changes?


#1

When I am making changes in my Mobile - Landscape and Mobile - Portrait views, the changes also happen on the desktop and tablet views. I only want these changes to be in mobile landscape and mobile portrait. How can I do this?


#2

Hey check to make sure that you have the mobile and tablet options turned off.


#3

It is not help, it is only hide object.
I have the same problem, not with all object, but sometimes I have to create copy of object and use it only on mobile screens (hidden on desktop and tablet).


#4

David Moore's advice is not accurate. That only controls the visibility of an element on each media query. When you create an element on desktop and change the parameters on phone or tablet, those changes only affect smaller devices. So create your element on desktop, then go to whatever device you want to modify and change it. Desktop should not change.

You should view the tutorials at http://tutorials.webflow.com/


#5

Hi guys, sorry to re-open this old issue. I'm having the same issue. When i make changes on mobile version or tablet version, all other devices are affected. Desktop does change. I would appreciate your help. Happy new year :smile:


#6

Hi @Niall_Mc_Dermott,

If you making changes in STYLES it should not effect desktop version. But if you change CONTENT (text, images) it will definitely be changed on all views.

Cheers,
Anna


#7

Anna, what is your workflow with copying objects shown only in the mobile versions?


#8

I just duplicate existing element, add combo class if it is necessary and style it for mobile version.
Then just using settings panel for set elements visible on particular screen types.


#9

Did´nt find out yet how to build a combo class


#10

GLOBAL CLASS
When you create new class

COMBO CLASS
When you add one more class to existing class. Just put cursore next to global class name and add one more class name.

How it looks in classes list:

In CSS code it will look like this:

.source-block.dark {
display: inline-block;
}

Regards,
Anna


#11

Great help thanks a lot! ::smile:
Gerhard


#12