Streaming live at 10am (PST)

MOBILE: Unwanted white space/scrolling space to right side of site


#1

Dear WF Community -

On all mobile versions (Tablets and phone versions) I have allot of unwanted white space and scrolling space to the right side of the site. Can someone please help me remove this from all mobile/tablet versions. The site is clean on desktop versions.

Please see attached image.

If anyone is wondering, the attached image is rendered for the iPhone 6.

Any and all help is gratefully appreciated!!

M


Here is my public share link: LINK
(how to access public share link)


Adjusting Images on Different Devices
#2

Our site address: www.useiami.com

Thx,
M


#3

Can you share your read only link?

https://help.webflow.com/article/how-do-i-share-my-sites-read-only-link


#4

Hey, @mickb

The reason of the overflow:
1) The element "pricing-h1" has width = 1260px. - change width to auto
2) "feautures-div-block" has negative right margins - probably better to use position: relative and move content with positioning (top, left, right, bottom)
3) "intro-pg-h3" - has big negative margins also - apply overflow: hidden to the container or the div

Regards,
Anna


#5

WOW Sabana - You are good!!!
I've just corrected it but there still are some spaces left and I can't seem to find the issues... :frowning:
Would you kindly look again?

M


#6

Hi @mickb, it will be easier for people to answer, if they can see the read-only link to the design view of the site, please post that with your questions if you can :slight_smile: http://help.webflow.com/faq/how-do-i-share-my-sites-read-only-link


#7

https://preview.webflow.com/preview/useiami?preview=05d19683aea44a2b75a6901feb2d5362

Cheers, M


#8

It is because of the button in the image and other content.

I recommend to get rid of the margin and rather use flexbox, I was able to get it to work and be responsive this way.


#9

Hey guys, been using Webflow for a week and love it but Im having the same issue. I got rid of all the negative margins but it didn't solve the issue. Can somebody help me? Still so new to this...

https://preview.webflow.com/preview/nwo?preview=9f8eaa1435eae4ab0072536b9a0231de


#10

@Hector_Castro The problem is with the images you are using as backgrounds.


#11

I got rid of them and the problem persists. What can I do in order to fix it?


#12

@Hector_Castro Here is the problem I am seeing with your background image: http://quick.as/Ad21im24w


#13

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.