Streaming live at 10am (PST)

Mobile usability issues flagged by Google related to Webflow code

I have a couple of odd mobile usability issues that have been flagged by Google in my search console:

• Viewport not set
• Uses incompatible plugins

Unfortunately, Google offers no further information, other than their ominous warning that “Mobile Usability may be negatively affected in Google Search results.”

Not being penalized by Google is of course paramount. Does anyone have any idea what’s up here?

My site’s URL: https://www.newyorkmultimedia.com

My share read-only link: https://preview.webflow.com/preview/nymm?utm_medium=preview_link&utm_source=designer&utm_content=nymm&preview=119da6ef9090f6d3bddce9c804b92f76&mode=preview

Thanks.

I suspect this is an issue you had before you migrated. Why?

<meta content="width=device-width, initial-scale=1" name="viewport">

This tag is on your site now. Therefore the report is not accurate.

1 Like

Thank you very much @webdev, for responding so quickly and tracking down the relevant code.

Unfortunately, I’m am not technically sophisticated. When you say “before you migrated,” what are you referring to? I’m not aware of any migration I did, or exactly what that means. (Unless you mean changing hosts, which I did about a month ago, but the Google alert came 3 days ago.)

I also don’t understand the code you pasted and what it means, or what or whether I should do anything to correct it…

Thanks again, and sorry for my confusion.

Before … as in May this year, your site was running a non responsive layout with Adobe Flash plugins.

That is a meta tag on your site that Google’s report says is not there. It is.
In fact I just audited your site with Lighthouse in Google Devtools which confirms what I see reading the source code of your home page.

Here is info about what that tag does.

Google Crawls billions of pages. Data gets aggregated and consumed in its big data systems, reports are run, emails and notifications are sent out. Sometimes there is a lag between the start and the end of that process. This is one of those cases. Since we can clearly see you aren’t running flash anymore and there is the correct tag in place. Which is why your site renders fine on my Galaxy S8+, my iPhones, and my iPads.

Your site is fine. There are a few issues you can fix according to Lighthouse but I would not sweat it. :slight_smile: Hope this helps you understand the issue and puts your mind to rest about the “issue”.

1 Like

Thank you so much, @webdev.

That’s a lot of expert troubleshooting on your part, and your explanation is really clear and really helpful.

Annoying that Google sends out alerts based on information that is so out of date. In the Search Console they falsely indicated that it was detected a couple of days ago, which is why it didn’t occur to me that they were flagging the old version of the site:

03

32

You are welcome. I have even had people call me to ask how an SEO guy that charged them $$ fixed the issue without ever touching the site. Mystery solved. :slight_smile:

1 Like