Streaming live at 10am (PST)

Modal menu covers content


#1

Hi there,

I Seem to be unable to get my modal menu to stop covering my main content. I hope that any of you can help me out with that. I’ve made it display flex/none on click of the menu button but after disappearing on the second click the interaction on the first big text is disabled. and I cannot really access the page itself anymore…

Thanks so much for you help!


Here is my public share link: LINK
(how to access public share link)


#2

Have you solved this? I don’t really understand the issue. When I wisit your site, the menu is already open, blocking the content. Is that it?


#3

Hi Vincent,

Thanks for your response, I’m afraid I left the page in the wrong state. I now have turned the menu off when opening the site. It works perfectly well In appearing but wether its visible or not, the main content keeps covered and thus there are no mouse-overs possible for the actual content. For example: the big text: “welcome to doks”, has the same mouseover as my menu buttons but it doesn’t get activated, I suppose it is because my menu keeps covering my body even when its set to display:none by animation.

Vriendelijke groet,
Kevin ten Thij

DOKS ontwerpburo
www.doksontwerpburo.nl
Sweerts de Landasstraat
61 6814 DB Arnhem
Tel. 026 44 38 328


#4

Hi Vincent, did you have a chance to look at my response? The problem is: the modal menu is not disappearing again, it will become transparency: 0% but the animation should then make it switch to: display:none. However, the mouseovers on the content behind it keep being blocked by it, so it must be in some way not going to display: none. Any idea how I can fix this?

It seems to me that I followed all the correct ways, maybe its a bug?