Streaming live at 10am (PST)

Modal Video CMS


#1

EDIT: I tried to add a video media element to a dynamic div in my CMS.

Here is my CMS set up:

The green video icon on my div appears when the video switch is on and a webflow native lightbox-modal appears when the icon is clicked. In this modal the video element is linked to the URL in my CMS.

The probem is that I have two seperate URL's but the same video displays for both divs when I click either icon.

Any ideas?


Thanks,


Here is my public share link: LINK
(how to access public share link)


#2

Hi @moofawsaw

Can you share your read-only link please?


#3

Here is the link

https://preview.webflow.com/preview/kyle-s-amazing-site?preview=1049efc55c0c6d3ebdbf263e1920a3d4

And here is the published page: http://kyle-s-amazing-site.webflow.io/.

Click the green video icon to see the modal.

Thanks for the help!


#4

I also need to get the like button from this post to sync with the save div/ CMS: https://forum.webflow.com/t/likebtn-cms-dynamic-items/35572

Right now both aren't tied into the CMS.

Thanks again,


#5

Hi @moofawsaw so the issue is that you have an interaction on the "Car Video Link" which is opening all of the "Card Video Modal" elements.

If you take your Car Video Link, and move it outside of your parent "Card" element so that it is a Sibling to your "Card Video Modal" element like this:

Then update your interaction to only affect the sibling elements then it will only pull up one modal at a time and the videos are playable as you can see in this clone of your site: http://kyle-s-amazing-site-1d99b2e4f85ef47925d.webflow.io/


#6

Thank you for the answer! It works great.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.