Streaming live at 10am (PST)

Muli font 300,500 (google) not uploading on webflow

Hi community,

I got some troubles uploading certain weights of the Muli font (google font).
Some of the weights are installed in Webflow and appears as an option but the following ones don’t:

  • Muli Light 300

  • Muli Extra Bold 800

I’ve been refreshing, closing/opening the page several times and nothing happens…

Someone in this kind would have an answer to this issue?

It would be greatly appreciate!

Many thanks,

Kevin


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Did you download the typeface files from Google and try to upload the desired font files in Webflow?

I’m probably missing something but why not just select the typeface in the Google Fonts dropdown, select the fonts you need and click Add Fonts?

Hi Vincent,

Sorry for being unclear. I download/upload the desire fonts in Webflow, like your screenshot.
The thing is, webflow show me that the weights font are being updated but when I go into my project the selected font weights are not available.

Really weird…

Prefer using the method in my image, you don’t have to download google fonts, they are available right in the Font panel of webflow site’s setting.

Just select the typeface in the list then select the fonts you need and voilà.

Hi Vincent,

That’s actually what I’m doing.
Here you can find, a screenshot with the fonts uploaded.
Going in my project, no options of using Muli 300 or 800…

You imported it thrice it seems, delete everything and add it again, with all the needed fonts at once, ending up with one line for the typeface, with all the fonts in.

Thanks Vincent.

I finally changed the font for another one and got all of them.

Cheers,

Kevin

(╯°□°)╯︵ ┻━┻

:joy:


1 Like

hahaa yes, I’m quite impatient. Will use Muli for the next one :upside_down_face:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.