Streaming live at 10am (PST)

Multi-reference from products not displaying

Is there any way to take fields from the e-commerce products collection and display them in a standard CMS collection using multi-references? I have been able to set this up ok, but can’t get Webflow to display the product field content. The test page I’ve built will display multi-reference content from other non-e-commerce collections fine.

My client who sells outdoor walking trips, and he’s asked that I add the ability to show list his products in a calendar.

This might have been straightforward if each trip was just listed as a separate product. But because he runs the some trips multiple time throughout a season it made sense to list some of his trips using variants. For various reasons this makes using the products collection as the base collection list impossible, not least because there is no way to have Webflow see variants as a date, hence no way to sort by date, which is kinda mandatory for a calendar!

So I had thought to simply build a separate “Calendar” collection where the client could add new entries bound to a real date field and then reference the products collection via a multi-reference field. It did mean a small bit of double entry for the client, but they understood what we were doing was a work around.

All went well, until I added the multi-reference field on the actual page. I can bind the field to an element - a text div for instance - but it simply does not display. I have another multi-reference field that is linked to a non-ecommerce collection and it displays fine.

Has anyone else encountered this? Any ideas on a solution?


Here is my public share link: https://preview.webflow.com/preview/wayymark-outdoor?utm_medium=preview_link&utm_source=dashboard&utm_content=wayymark-outdoor&preview=fa7882b58201d23f46f4e8d7c3366825&mode=preview

The relevant page is outdoor/outdoor calendar

Hey @Lucas_Wild the ‘Listing 2’ field is blank (no associated products selected). If you select one there, then would that enable it to display?

OMG - thanks so much Esteban. Such a schoolboy error! Problem solved.