Streaming live at 10am (PST)

Multiple HTML 5 video elements not autoplaying in Chrome mobile


#1

I have been working on a concept for a new site and have encountered an issue with autoplay of videos on mobile, I'm not sure if it is intended behaviour or something that can perhaps be fixed. Details below...

Preview link
Live site link

I have several videos on a single page. These all load and autoplay fine on desktop, but on mobile their behaviour is not consistent. In particular I'm seeing issues in chrome on mobile. The first video on the page will autoplay, but the rest of the videos will not. Safari doesn't seem to have an issue here, and will autoplay all videos on the homepage when they come into view

I have searched online for an answer to this and have found some people say that this is expected behaviour, in that chrome will only allow autoplay of the first inline video on a page. I haven't been able to find any official confirmation of this though. All videos are set to - playsinline autoplay loop muted.

If anyone is able to suggest a fix to this issue, or indeed to just confirm that this is the expected behaviour that would be appreciated!

Many thanks


#2

Videos don't autoplay or play inline on mobile, wether it's iOS or Android.

Apparently it starts to be supported on safari iOS but I haven't played too much with the feature.


#3

I appreciate your reply, but I believe you are wrong. Autoplay does appear to be supported for both Android and iOS as of summer 2016, as referenced here and here. Unfortunately there isn't a whole lot of additional information out there at the moment!

My problem specifically is with Chrome, which seems to only play one of the videos on the page on mobile. I suspect this may be an intended limitation to stop unwanted / excessive data use on mobile connections, but I'm not sure.


#4

I didn't want to be too specific. I tried to make it work on iOS, saw it running once only :slight_smile:

On Android there's actually an API for that but you need serious code to use it and the code varies depending on the version of Android.

You're probably right. The reason they weren't allowed at first were performances and experience.

Depending on versions, there are many tricks around... for some versions, adding the "mute" property seems to do the trick.


#5