Streaming live at 10am (PST)

Multiple Multi-Image Items on one CMS page displaying white when live

Hello! Having the hardest time with an aspect of my portfolio site and would really appreciate a new set of eyes! This is likely more complicated than it needs to be… I just wanted to have super flexible project pages.

I have each project setup as a separate CMS item. Inside each CMS item I have multiple Multi-Image fields, Text-Fields, and a toggle that turns “on” each section with Conditional Visibility. All of the multi-image fields show great when working in Webflow. However, when I preview it shows blank white spots the size of the content on the live site - the images are missing. When I right-click though, I can open the images. It makes no sense to me! What am I missing? The first multi-image section displays great but anything after that is invisible.

Here’s my read-only link.

Live link is here.

The source code shows the image HTML being loaded so I would look at setting the images to load “eager” instead of “lazy”. If that does not resolve it then try to pinpoint the issue by removing the interaction bound to .workimages to see if that is the problem. It could be the combination of the two (lazy and IX2). Hard to test from my end.

1 Like

@webdev - Thanks so much for the help. It’s the .workimages interaction looks like. Turned it all to eager and no change. Kept lazy on and turned off interactions and like magic, images loaded just fine. Which is really bizarre because the first set of workimages loads just fine with them both on. It’s the subsequent ones that don’t show at all. Seems like some sort of bug when multiple workimages are on screen. I thought perhaps it was because the offset was too high but switched it to 0% and no luck still. Knowing that, is there anything else to be done really? Or is the best solution to just turn off the interaction. I use it all over the site without problems so I’m unsure there’s a fix.

For now I’m deleting the interaction. If anyone has had this problem before and knows a good fix, I’ll give it a try. Thank you!