Streaming live at 10am (PST)

My entire mobile site is messed up

Ive been building my website for a couple months now slowly, while learning Webflow. I come to the point where I want to put the actual content. I did for the most part but on my iPhone its messed up on some pages on landscape mode but not portrait mode. I don’t know what’s wrong because on the mobile preview everything looks fine.

Here’s the Read only link:
https://preview.webflow.com/preview/clout-1d4485?utm_medium=preview_link&utm_source=designer&utm_content=clout-1d4485&preview=afc1f2f263139c740c6f8fe7d7234695&pageId=6012d805a8468122b768e3b1&mode=preview

Example1 :
on the Event photo page, it doesn’t show the first two slides on portrait mode.

Example2:
the portraits page on horizontal doesn’t let me leave the page unless I switch to portrait mode.

Example3:
On my events Video Page, the loop video I have doesn’t play on the mobile versions at all.

I just want to know where I went wrong so I can fix this mess. no website = no money coming in.
Thank you in advance for anyone who can help.

hi @Jose_Reyes video doesn’t play on mobile automatically because of policy restrictions since 2018 and you can read more here or find some responses here on forum how to solve it as eg. in this Article

The rest of your issues are related to your CSS code.

I have looked on your page on mobile and it was stocked with uploading. I was waiting 1 minute to see if page load fully but still was frozen on 30% so there may be another issues.

Good luck

1 Like