Streaming live at 10am (PST)

Naked URL (no www.) not working after following instructions. Help!


#1

Hi Guys,

I've read the other threads on this topic but nothing seems to be working.

Changed my DNS settings in GoDaddy and followed the instructions - but Webflow is still displaying error messages:

Can anyone see where I'm going wrong here?

Thanks,
Michael


#2

You are supposed to use CNAME records instead of A records for SSL.

These are my CNAME records, notice I do not have any A records for the root domain and www subdomain.


#3

Hi Sam,

Thanks for getting back to me.

I tried to add another CNAME as per your suggestion, but GoDaddy tells me: "This CNAME already exists in this zone". But it doesn't... super confused.

Also, do I need to get rid of the A records that the Webflow message told me to add?

Thanks in advance!


#4

@samliew so confused!


#5

Sorry, I do not see any CNAME records

Please transfer your domain name to Google Domains or Namecheap if you require further assistance.


#6

The CNAME records are in my GoDaddy DNS Manager dashboard, so not sure why you can't see them.

I'll try and find help elsewhere. Thanks anyway.


#7

@cyberdave Hi Dave - sorry to bother you. You seem really knowledgeable and helpful in the other forums threads I've read. I'm hoping you can help me.

I've enabled SSL for my new site. Now I'm just trying to get my domain without www. in front of it redirected, so as not to confuse Google. Webflow is showing me an error message (see screenshots in first post above), so I added the A Records in GoDaddy. But even after adding these records the domain is still showing as 'Unlinked'.

Can you help?


#8

Can any staff at @webflow help at all? I'd really love to get this sorted today and I've tried my very best to figure out where I'm going wrong.


#9

Hi @WCOC, thanks for reaching out. From the screenshots, I can see that SSL is in use, and the A Records are setup now for the root domain to point to our proxy server IPs, and those appear to be setup correctly. You should also setup one CNAME record for the host "www" and Target should be proxy-ssl.webflow.com.

Take a peek at this article that shows the steps needed to enable the SSL: https://help.webflow.com/article/how-to-enable-ssl-on-webflow-sites

We use those ip addresses for customers having domain names registered at services who do not yet support CNAME or ALIAS records for the root domain. The root domain in this case is whippersnapperschildcare.co.uk.

When using the A Records that start with 34 as in the above image, the www domain in Webflow should to be set to the default, so that

  1. Traffic on the root domain will go through the SSL proxy server
  2. Google knows it is a permanent 301 redirect. http://help.webflow.com/faq/how-to-set-your-sites-default-domain.

If you must use the root domain whippersnapperschildcare.co.uk, the options would probably to use a service like cloudflare, or dnsimple for your domain service provider. Changing to one of those providers will let you use a CNAME or ALIAS record on the root domain, pointed at proxy-ssl.webflow.com, which allows you to set the root domain as the default in Webflow.

I hope this helps, if I can help further, send an email to support@webflow.com and I am happy to take a look further.

Thanks in advance!


#10

I've had to email you, sorry @cyberdave :frowning:


#11

This topic was automatically closed after 60 days. New replies are no longer allowed.