Streaming live at 10am (PST)

Nav Bar Buttons Disappear Once Clicked?


#1

I have created Nav Links for my menu and when I view in preview mode, once I click the button and it takes me to a page, that button disappears... I have a hover effect on the button but no pressed effect (that I'm aware of) but do not see any settings that would accidentally turn the button background and text white. Do I need to change a certain setting or add a pressed effect to eliminate this problem?


#2

Hey Rachel, speaking from personal experience here I don't think nav bars carry over across multiple pages with whatever styling like a smart object / symbol (symbols are yet to be implemented into webflow). Did you copy over your latest nav bar and paste it into this new page then tweak the active link?


#3

Hi Richard, thanks for your response! I'll try pasting the nav bar to each page again and see if that fixes the problem. But, the weird part is that when I hover over the "disappeared" button it shows the button in "hover mode" so the actual button is still there it just appears that somehow the background and text of the button turns white or transparent after I click it.

I also realized it's the previous page I was at thats button is invisible. So if I press the "Contact" button from the "Home" button, the "Home" button is the one that is invisible not the button for the page that I'm on...


#4

Hi Rachel, you're welcome. It sounds like a class or inherited style is being applied that you're not aware of. You might need to dig into your styles and see if anything is over writing what you want for the hover state to be.

If you're still stumped paste the link to your site here and I'll inspect in chrome.


#5