Streaming live at 10am (PST)

Nav Bar interaction not working

Hi all,

I’m trying to build a full screen mobile nav that pops up when you tap the menu icon. I’ve gotten the interaction to work to close it but I can’t get it to work to open. Weirdly enough if I apply the interaction to my logo image it works as it should if it was applied to the menu icon

Any help is appreciated


Here is my public share link: LINK
(how to access public share link)

Hello :slight_smile:

Please could you share your Read-Only link so that I may take a look and try and assist.

@Nicole_Klaver

https://preview.webflow.com/preview/davids-portfolio-starter-317305?utm_medium=preview_link&utm_source=designer&utm_content=davids-portfolio-starter-317305&preview=832e0002f5b7e5b720202ab42b4fe9fa&mode=preview

Here you go! thanks

Hello :slight_smile:

Try moving ‘hammy wrapper’ into ‘Container 5 Copy’ within the first ‘Navbar’. What’s happening is that it wasn’t sitting on the same level as your navbar and so it wasn’t able to be selected.

Let me know if you come right, otherwise, I’ll make a quick video :slight_smile:

@Nicole_Klaver thank you so much! I dont think I understand why that kept it from being able to be selected… but it worked!

Not a problem - I’m glad you came right :slight_smile:

Within the design there are multiple layers - where some things sit higher up than others. If you have a layer over an object that’s clickable, or if the clickable object is under another layer - it won’t select. Sorry if my explanation is confusing.

Happy Webflowing! :slight_smile: