Streaming live at 10am (PST)

Nav Bar Issue on mobile view


#1

@cyberdave
So I was having an issue with my navbar not working correctly on mobile and tablet view so I created a second symbol and the views for the 1st navbar are set to desktop and tablet only then the symbol for navbar mobile is set for landscape and mobile only. The issue is that although all my interactions are the same in mobile and landscape view the navbar auto shows up vs being hidden and needing to click the hamburger to get it to show? Any assist would be awesome


Here is my public share link: https://preview.webflow.com/preview/element-parkcity?preview=6cf0cc0ce45935328595eadd2d121f52


#2

Hi @rsilbereis, it looks like something in the Navbar mobile Nav Menu got corrupted, I can see that there have been some changes to the widget (i.e. the container was deleted).

I am not exactly what has happened, but the quick fix is to drag another navbar to your page, then drag the Nav Menu from the new navbar widget, into the Navbar Mobile navbar.

You will need to delete copy or drag the old menu links from the old Nav Menu into the new Nav Menu.

Once that is done, you can delete the old Nav Menu div that is under the Navbar Mobile navbar.

Let me know if you have any questions.


#3

@cyberdave Thank you. I tried this and it fixed the home page landscape version however the mobile view now does not show the hamburger and the subsequent pages did not update although they are all linked via a symbol?


#4

@cyberdave

if you have a minute: I tried this and it fixed the home page landscape version however the mobile view now does not show the hamburger and the subsequent pages did not update although they are all linked via a symbol?


#5

Hi @rsilbereis, i just checked and the mobile menu is showing and working for me on all views.

Can you create a screencast or a screenshot how it looks for you on mobile ?


#6

I just manually changed each page. For some reason changing the symbol was not affecting each page. Thank you!


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.