Streaming live at 10am (PST)

Nav bar links only working in desktop layout?

Hey everyone! I’m having a hard time with the links in my Nav Bar. They are working perfectly in desktop, but not working at all in tablet or mobile. I tried re-creating the links and am having the same problem. I originally had linked text in div blocks, and now I have link blocks with text inside. Neither have worked. Please help!


Here is my site Read-Only: https://preview.webflow.com/preview/portfolio-site-c97bee?utm_medium=preview_link&utm_source=dashboard&utm_content=portfolio-site-c97bee&preview=2ed16bbb642bbfba24c574da1529d223&mode=preview

Live site published link: http://ally.camp

I believe it’s because you have negative margin applied to elements below the nav bar - in mobile view this seems to make them overlap your nav bar and sit in front of your links.

EDIT: here is how it looks when you show all of the div boundaries… If I hide everything below the navbar in mobile view, the nav links work perfectly:
2019-10-08_15h48_09

@Andy_Vaughan ah, I see! I’m new working with webflow and could not for the life of me figure out what the issue was. I moved the container and hero down out of the way and now it’s working perfectly! thank you so much!

1 Like

No problem at all, glad to help as I’ve received so much friendly advice through these forums myself!

Please consider marking that post as “Solution” if it was the right answer! :smiley:

@Andy_Vaughan got another question for you if you can take a look!

The mobile version has all this extra white space, but only when I look at it on my phone (not when looking @ mobile version on desktop)
and there’s a little random square on the screen. Any ideas?

This is the link:
https://preview.webflow.com/preview/portfolio-site-c97bee?utm_medium=preview_link&utm_source=designer&utm_content=portfolio-site-c97bee&preview=dc9170089839cd5e6a60d3c39f3fd438&mode=preview

Think I know why this is, give me a few mins to check and walk you through it…

1 Like

So, I think it’s all to do with your animations and setting the initial state of your elements off-screen.

For any element which you have animated and which starts off-screen (e.g. the Hero Img that you have animated in the “Hero Img Animation”) I believe you need to “hide overflow”. I’m not sure if that should be on the element itself or on the animated element’s parent div.

Obviously if you have multiple animations starting off screen, you need to hide the overflow of them all.

Below is an image of the Hide Overflow setting:
2019-10-08_21h31_11

I hope that helps, it’s tricky to tell for sure what will work as I can’t publish this and test myself.

Sorry to triple post!

I knew I had the same issue recently, I just couldn’t remember which of my projects it was in… just found it!

I’m sorry that I can’t share the project with you, however hopefully I can explain well enough.

In this screenshot below, you can see which element has an animation applied to it. That element has an initial state of starting 150px to the right of the screen, and so I ended up with the same white space as you.

What I did was apply the “hide overflow” to the animated element’s parent (highlighted in blue in the screenshot)
2019-10-08_21h33_27

@Andy_Vaughan that fixed the problem! YOU ARE MY HEROOOOO :heart_eyes::star_struck:

1 Like

Awesome! 2/2 so far haha :smiley:

Unfortunately you can only tag one reply as “Solution” in any topic. May I advise that you tag my original response as the solution? This is so that anyone viewing this topic with the same problem that you originally raised in the future can jump straight to the right solution :slight_smile: