Streaming live at 10am (PST)

Nav Bar Problem: Full Screen Menu Unresponsive


#1

Hi there!

Having created a custom nav bar, hamburger + interaction and menu popup, the central section of the menu becomes unresponsive once open. Only the area below the central nav bar space is unresponsive.

I have no idea why this is happening since the hover animations work perfectly in the design screen ad the nav bar or its container isn’t covering any of the menu.

I would love another pair of eyes on this - thanks everyone!

TJTJ

Here is my site Read-Only: https://preview.webflow.com/preview/growthhat?preview=39af5d90ecffdae055d9579a6bda743e


#2

Anyone? This is really quite urgent as the delivery is for the end of the day! @samliew is there anything you can think of?


#3

Hi @tjthomsonjones

I think part of your custom nav setup may be using my cloneable hamburger/fullscreen menu, so wanted to reach out and see if I can help! (Awesome to see it evolved if so!)

I’m guessing there could be some z-indexing or link block issues, but just to check is there any custom code added?


#4

Hey Dude,

Sure am! Works beautifully and links to the pop up nicely but seems the exact spacial width of the navbar is unresponsive on the popup. I would understand there would be a z index issue over the navbar, but it is in an area where the nav bar doesn’t cover - weird!

Let me know if you uncover any mysteries!

Thanks for taking a look


#5

Get rid of the default Webflow Navbar component. It was causing an issue because your trigger nav btn was inside the default mobile menu btn.

Build a custom top bar with your branding and the trigger btn.

View this gif for example:
CloudApp


#6

Thanks for that Phillipe thats sorted the problem!!


#7

Boom - thanks for stepping in @philippe :grinning:

Slaying those deadline day issues like: