Streaming live at 10am (PST)

Nav Link - Current with txt decoration - underline


#1

Hi,

In the designer, only the home page link has the underlined link, but in preview mode, the other links do not. In editor, I see the instance listed as Current - possibly a pseudo class. When the site goes live, will the other nav links have that persistent link when the specific page I am on is selected (automatically)?

Or should I be seeing that behavior in the preview mode?

Thank you.


Here is my public share link: LINK
(how to access public share link)


#2

Hi,

The current class is automatically added to only the links that go to the page you are on. Likely what you did was styled the current class by accident, which will not affect the parent class. To undo this, choose another link in your navbar that does not link to the current page and add a class if you haven't already. Then style it how you want them all to look. Then add that class to all the links including the active one. Then select the active style and click any blue styles in the current class and click remove this style. I know this can be confusing if you aren't used to working in Webflow.

If you find yourself lost again, post your public share link so we can see what's going on and give you better instructions.

Good Luck!


#3

one thing i should clarify... links are working properly. i can jump from page to page by clicking any nav link. - good there! It is the persistent 'text-decoration:underline' of what I believe is called the active state I am not seeing applied to all pages with the exception of the homepage. If my template came with that built in, I do not see how that style could have been broken because all of them do underline when i mouse over in preview mode.

Any more suggestions before I did in to investigate some more? Thank you!


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.