Streaming live at 10am (PST)

Nav Link Help - Multiple Pages

Hi, I’m redesigning my portfolio and need some help with the nav links. In the preview mode, the “Contact” link works, but when the site is launched it only works on the home page. Any help or tips would be greatly appreciated.

Thank you!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

1 Like

Seems to be working for me. I tested this page and it scrolls down to your contact area. Maybe you figured it out?

https://mattblairportfolio.webflow.io/vikingdemolition#Contact

1 Like

Thanks for taking a look at it. The Viking Demolition page works, but the Spotify and UI Designs page does not work. I’ve copied the “footer” section from the Viking page and it is odd that it works for that one but not the other two?

I see.
You just need to select that footer elements and then go to the setting panel and give it an ID of “Contact” see attached.

While in settings, I’d go ahead and change the div tag to “footer” :slight_smile:

Another way to keep it consistent is to make that footer div a symbol too.

1 Like

Alright, making them symbols was a great idea, and I did that to the nav, and footer for consistency. It is odd it works in preview, but when I launch site just the home page and Viking page work for the “Contact” link.

Hmm. Not sure. Have you published it since making the change?

When I test your published page, the link is still trying to take me to “#contact” but in your file it looks like you changed it to “#contact1” ??

1 Like