Streaming live at 10am (PST)

Nav link hover issue

Hi folks,
My client wishes to have a simple navigation (2 links) when you rollover each link a sub/dropdown navigation appears on hover. I have this working as they expect, however on various browser breakpoints the rollover movement from hovering over the nav link and moving the mouse to the sub-nav, doesn’t work very well. I could nudge the navigation dropdown area up a little but then it’s blocking their logo. It’s becoming problematic! Before I alter this to become a click/open instead, is there anything else I could do here to make this work a bit smoother?
Also; when the dropdown area is open, you can scroll downwards with the mouse whilst it stays open. Is there a way to prevent this?
https://mervue-natural-skincare.webflow.io/


Here is my site Read-Only: [LINK][1]
([how to share your site Read-Only link][2])

https://preview.webflow.com/preview/mervue-natural-skincare?utm_medium=preview_link&utm_source=designer&utm_content=mervue-natural-skincare&preview=56f0db7f684b75a9dc125de38896992b&mode=preview

Hello.
I don’t know if this helps, but the link blocks are on top of each other. So when you hover over the second link the first menu disappears. That’s how it should be.
I think you have to move the submenu’s directly under the link blocks!
Or put the links next to each other?

Hi,

No it’s more when you rollover the Nav link ‘Products’ or About Us’ and it opens the dropdown area, on certain browser breakpoints when you move the house over it close the dropdown area again.