Streaming live at 10am (PST)

Navbar changes from page to page


#1

I am working on creating a centered navbar that is the same across my entire website.
On the home page, everything looks fine and works perfectly.

However, as soon as I navigate to a different page, everything seems to be out of place.

This is the correct look:

This is how it looks on other pages:

Thanks for your help!


Here is my public share link: LINK
(how to access public share link)


#2

Hi @carlsson,

Did you try to create Symbol from "correct looking" Navbar and use it on other pages? Symbols are very helpful when you have same elements across whole website.

Cheers,
Anna


#3

Hi @sabanna, and thanks for your response.

I have tried creating a Symbol, but it does not seem to be helping. I have created a "Navbar" symbol using the correct layout on the front page. But when I drag onto a new page, it's not displaying correctly.


#4

Hi @carlsson thanks for joining the community! :smiley:

Try removing your logo's link first:

Then style it appropriately, then add the link back to it. The reason for this style issue is the pseudo class "current"

​Try these steps and let me know if you're successful. I'll be standing by for your response! :slightly_smiling:

Cheers,
Nelson


#5

@PixelGeek -- thank you so much! I swear I had tried styling with and without the "current" class, but I think I for some reason the non-current logo was displayed as a block instead of an inline block, which seemed to have caused the problem.

Again, thank you for your help, and thank you for this amazing product! :smile:


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.