Streaming live at 10am (PST)

Navbar problem in landscape on tablet


#1

Landscape mode on a tablet is the same as on the desktop. I understand that and that is why i am puzzled by why my navbar appears the way it does on my iPad. On the desktop, the navbar links are displayed inline-block but on my iPad they appear stacked one on top of the other. Additionally, the main logo doesn't appear on anything but the desktop version although it appears in preview mode at every break point on my computer. Can someone tell me why? Public link is here.


#2

Hi Anthony could you please check and repost your public link? it's not working for me.


#3

@vincent, I edited the original post and updated the link. Thanks for taking a look.


#4

@vincent any luck recreating the issue i am having?


#5

I just looked, no. Could you show me a screencap or photo of what you get on ipad?


#6

why are you embedding code - and not using the nav widget ?

<ul class="w-list-unstyled sb-menu">
            <li class="sb-close"><a href="index">Home</a>
            </li>
            <li>
                <a class="w-inline-block sb-toggle-submenu" href="#">
                    <div class="w-embed">
                        <p class="sb-toggle-submenu sb-submenu-active" style="line-height: 20px; font-size: 14px;">Company<span class="sb-caret"></span> 
                        </p>
                    </div>
                </a>
                <ul class="w-list-unstyled sb-submenu">
                    <li class="sb-close"><a href="#mission">Our Mission</a>
                    </li>
                    <li class="sb-close"><a href="#testimonials">Testimonials</a>
                    </li>
                    <li class="sb-close"><a href="#aboutus">About MILPRO</a>
                    </li>
                    <li class="sb-close"><a href="#staff">Our Staff</a>
                    </li>
                </ul>
            </li>
            <li class="sb-close"><a href="services">Services</a>
            </li>
            <li class="sb-close"><a href="rentals">Rentals</a>
            </li>
            <li class="sb-close"><a href="sales">Sales</a>
            </li>
            <li class="sb-close"><a href="resources">Resources</a>
            </li>
			<li class="sb-close"><a href="contact">Contact Us</a>
            </li>
        </ul>

Is this what you are talking about ?


`


#7

Your nav is not set to be visible in tablet mode or lower.

So what you are seeing on the left.. is your embedded code.

So I'm guessing - that's what you want....

and the real question is - why is the embedded code not executing in Preview ?

Because Custom and Embedded Code requires a Published or Exported site.


#8

@Revolution I realize that embedded code won't render correctly until a site is published. The view that I get in desktop should be the same view that I get in landscape on a tablet but it isn't and that is the issue that I asked about. The reason that I am using embedded code is because it is much easier than reworking the structure of the navbar widget to allow clicking on either the main link or one of the links in the dropdown. I also like the subtitle text under the main link.


#9

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.