Streaming live at 10am (PST)

Navbar / Scroll - too dizzy to continue, videos don't help, just want to connect navbar links to a section - rename is a hassle too


#1

Hi all,

New to webflow - have exp. with Dreamweaver, XSitePro, & others, so I'm not that inexperienced, however, I've spent almost a week trying to master Navbar/Scroll, but why is it so difficult to name menu links & link them to a Section?

I've seen the video but they don't really help as the interface is different & are done too fast without much explanation.

I'm at my wits end, and Dave & Dfink, I tried what you suggested by it wasn't that clear to me however. Again, the video need to be slowed down.

Thx


#2

Then, honestly, maybe Webflow is outside of your capabilities. I found every video to actually be kind of slow even from the start. I was able to pick it up pretty quickly and refer back to the videos if I ever got stuck. You can pause videos and replay sections over and over, until you figure it out.

Linking a navbar element to a section is one of the easiest things to do in webflow. First, select the section, go to the settings, name it in the ID section. Then go and click it's corresponding link to select it, go to the settings panel and choose in page linking and choose that section. Incredibly easy!

Did you try doing all the beginner videos here http://tutorials.webflow.com/beginner-course/learn-to-build-websites-without-code-fast-beginner-course


#3

I know, I have most links connected except 2, so I looked at the others & made sure they are set the same, but nada. I've followed the videos & like another user here experienced, it didn't make sense. In Dreamweaver, it took a few seconds to link a page. So I don't know now, too frustrated.


#4

Dreamweaver is honestly awful so at least you are on a better program now. I made a quick video for you. http://quick.as/7DQRUrRD


#5

Like I said, linking was easy in DW, not like here. And again 2 links don't work with the same settings as the others that do work. thx for video, will look at it now and see if I can fix those effing links - see for yourself if you want - https://webflow.com/website/mohawkgirls - thx again


#6

I had already done exactly what you showed & it doesn't work. (2014 screening - link)


#7

So the navbar scroll works fine. It's the top navbar that wasn't working. You have to go in and isolate the top navbar. Then select the link and remove the in page linking and re-add it. Fixed it for me.

I would also just select the scrolling navbar that right now sits on top of the other one and change it's display to hidden. It does not need to be visible unless you are working on it. Just change it to hidden and leave it like that. The interaction will still work fine.


#8

Each time I select a link, it flips to Navbar scroll - also when you say isolate Navbar, you mean from Navigator? - thx DF


#9